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Chapter 1 EasyBuilder Installation and Startup Guide 

 

1.1 EasyBuilder Installation 

 

Software: 

Download EasyBuilder from CD or visit Weintek Labs, Inc.ôs website at 

http://www.weintek.com. The language versions include Simplified Chinese, Traditional 

Chinese, English, Italian, Korean, Spanish, Russian, and French. The latest upgraded files 

can be downloaded too. 

 

Hardware Requirements (Recommended):  

CPU: INTEL Pentium II or higher 

Memory: 256MB or higher 

Hard Disk: 2.5GB or higher (Disc space available at least 500MB) 

CD-ROM: 4X or higher 

Display: 1024 x 768 resolution or greater 

Keyboard and Mouse 

Ethernet: for project downloading/uploading 

USB Port 2.0: for project downloading/uploading 

RS-232 COM: for on-line simulation  

Printer 

  

Operating System: 

Windows XP / Windows Vista / Windows 7. 

http://www.weintek.com/
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1.2 Steps to Install EasyBuilder 

 

1. Installing EasyBuilder: 

Put the disk into the CD drive. The computer will run the program automatically or execute 

under the root directory [Autorun.exe] manually. The installation screen is shown below. 

 

 

 

2. Click [Install], the dialog below is shown, select the language and click [Next].  

 

 

 

 

 

 

English Spanish French Italian

Simplified Chinese Traditional 

Chinese Korean Russian. 
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3. To remove the old versions of EasyBuilder, please select the check box and click [Next]. 
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4. Designate a new folder for EasyBuilder installation or use the folder recommended and 

then click [Next]. 

 

 

5. Select a start menu folder to save the programôs shortcuts. Click [Browse] to designate a 

folder or use the folder recommended then click [Next]. 
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6. Users will be enquired if there are any additional tasks to be done. For example: [Create a 

desktop icon]. Select it if needed then click [Next] to continue. 

 

 

7. When finish settings, please check if they are all correct. If any changes need to be made, 

click [Back] to change the settings or click [Install] to start installing. 
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8. Installation processing. 

 

 

9. Click [Finish] to complete the installation. 
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10. The EasyBuilder shortcuts can be found in [Start] » [All Programs] » [EasyBuilder]. 

 

 

The description of each item in EasyBuilder menu: 

Installed file Description 

EasyAccess Managing tool for HMIs connected in network. 

EasyBuilder 8000 EasyBuilder project editor. 

EasyConverter Conversion tool for Data Sampling and Event Log. 

EasyDiagnoser Tool for detecting the connection between HMI and PLC. 

EasyPrinter Remote screen hardcopy and backup server. 

EasySimulator Execute simulation without installing EasyBuilder. 

EasyWatch Via PC to monitor or set HMI and PLC address value. 

Project Manager EasyBuilder managing tool. 

Recipe Editor 
Tool for setting the format of Recipe data. Users can open Recipe 
data or data in the External Memory here. 

Release Note Software release notes. 

Structure Editor 
Supports AB TAG and improve the flexibility to read / write an 
object. 

 

 

ƴ HMI support downloading/uploading projects via USB cable. After installing EasyBuilder, 

please go to [Computer Management] » [Device Manager] to check if USB driver is installed, 

if not, please install it manually. 
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Chapter 2 Project Manager 

 

After installing EasyBuilder, double click [Project Manager] shortcut on the desktop to start. 

Project Manager is for launching several utilities and it is a stand-alone program. 

To launch EasyWatch, please open EasyBuilder first. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Launch EasyBuilder 
to edit projects. 

After rebooting, the 
system returns to the 
initial condition. 

Conversion tool for 
Data Sampling/ 
Event Log. 

Remote printer 
/backup server. 

Extended Memory 
and recipe editing. 

Review the address 
ranges and formats of 
supported PLCs. 

On-line monitoring 
and debugging tool. 

Save the data in 
CF/SD/USB to 
download to HMI. 

Allow other PC 
applications to 
connect PLC via 
HMI. 

Connect via USB 
cable or Ethernet to 
check the HMI history 
files information. 
 

Set password here 
before operating HMI 
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2.1 HMI IP, Password  

 

[Settings] 

When operating HMI via Ethernet or USB 

cable, please set the password for HMI to 

protect against unauthorized access. 

 

[Reset / Download] functions share the same password while [Upload] function uses 

another one. 

 

Â Please remember the password, otherwise, while restoring HMI default settings, the 

project files and data in HMI will be completely erased. 

 

[Reboot HMI] 

Reboot the HMI without unplugging. After 

reboot, the system returns to the initial state. 

Set the correct IP address when rebooting 

HMI via Ethernet. 

 

[Data/Event Log File Information] 

BAfter setting, connect with HMI to check the 

number of history files in HMI. 
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2.2 Editing Tools 

 

2.2.1 Build Download Data for Saving in CF/SD Card or USB Disk 

 

 

 

1. Insert the external device (CF/SD card or USB disk) to PC. 

2. Assign the folder to store data. 

3. Select source files for project, recipe (A) and data log. 

4. Select [Build] to create files for downloading. 

 

The source files will be saved in the inserted device for users to download to HMI without 

connecting via a USB cable or Ethernet. 

 

 

 

 

 

 

 

 

 
77 
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2.2.2 Steps to Download Project to HMI via USB Disk or CF/SD Card 

 

Assume we will download data in the folder named ñ123ò (K:\123) on an USB disk. 

 

1. Insert USB (in which project saved) to HMI. 

2. In [Download / Upload] dialog box select [Download]. 

3. Enter Download Password. 

4. In [Download Settings] dialog box, select [Download project files] and 

[Download history files] check boxes. 

5. Press [OK]. 

6. In [Pick a Directory] dialog box, select directory: usbdisk/device-0/123. 

7. Press [OK]. 

Project will then be updated. 

 

 

Â If only the history files are downloaded, it is necessary to reboot HMI to update files. 
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2.3 Transfer 

2.3.1 Download 

Download files to HMI via Ethernet or USB cable. 
 

 

 

 

[Firmware] 

Update HMI kernel programs. The firmware must be downloaded at the first time 
downloading data to HMI. 

 

[Project] 

Select an xob file. 

 

[RW / RW_A]  

Select a rcp file. 

 



                                                                    Project Manager 

 23 

[Data log] 

Select a dtl file in datalog folder. Select the data sampling folder in HMI and then select a dtl 

file. 

 

[Install X-series media-player drivers] 

Necessary when first time download data to X series HMI using EasyBuilder8000. 

 

[Startup screen] 

Download a bmp bitmap file to HMI. After HMI is rebooted, this bmp file will be shown before 
project starts. 
 

[Reboot HMI after download] 

Automatically reboot after download. 
 
[Reset recipe] [Reset event log] [Reset data log] [Delete startup screen]  
Erase the selected files in HMI before download. 
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2.3.2 Upload 

Upload files from HMI to PC via Ethernet or USB cable. 

Click [Browse] and assign the file path before uploading. 

 

For [Project], [RW / RW_A], or [Data log], please refer to 2.3.1. 

 

[Event log] 

Upload the evt file in HMI to PC. 

[Extended Memory (EM)] 

Upload the emi file saved in CF/SD card or USB disk to PC. 

 

 

Â The file will be uploaded to PC in xob format. Please decompile it into editable mtp file 

first and open the mtp file in EasyBuilder. 

Â To upload the historical files saved in the external device, please use FTP. See 

ñChapter 32 FTP Server Applicationò for more information. 
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2.4 Simulation 

 

2.4.1 Off-line Simulation / On-line Simulation 

 

Off-line simulation: Simulate project operation on PC  

without any connection. 

 

 

On-line simulation: Simulate project operation on PC and 

PLCs are directly connected with PC. 

 

 

 

Â When using [On-line simulation] on PC, if the target device is a local PLC (the PLC is 

directly connected to PC), there is a 10 minutes simulation limit. 

OK without HMI 

&PLC and save 

more time 

No need to 

download project 

to HMI. 

Simulate 
operations without 
connecting PLC. 
 

Connect 
PC-PLC & set 
correct 
parameters to 
operate. 
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Before executing On-line/Off-line Simulation, please select the source *.xob file. 

 

When executing on-line/off-line simulation, right click to use these functions:  

 

[Exit simulation] 

Stop simulating. 

 

[Run EasyDiagnoser]  

To monitor current communication 

status. 

 

[Screenshot]  

Capture and save current screen 

image as a picture file in the 

screenshot folder under the 

installation directory. 
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2.5 Pass-Through 

 

This function allows the PC application to connect PLC via HMI. In this case, the HMI works 

like a converter. 

 

Pass-through provides two modes: [Ethernet] and [COM port].  

When using [Ethernet], please install the virtual serial port driver first. 

 

 

For more detail, please refer to ñChapter 29 Pass Through Functionò. 
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Chapter 3 Create an EasyBuilder Project 

 

The following is the basic procedure to create a project. 

 

 

 

 

 

 

3.1 Create a New Project 

1. Launch EasyBuilder 

2. Open a new file. 

3. Select [Model]. 

4. Tick [Use template]. 

5. Click [OK]. 

6. Click [New]. 

7. Set parameters. 

8. Click [OK]. 

 

9. A new device is added into 

[Device List]. 

 

 

 

Save & 

Compile 

Download 

to HMI 

 

On-line 
Off-line 
Simulation 

Create a 

Project 
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Now letôs add a new object. 

1. Click on the object icon  to create a Toggle Switch object. 

2. Set the address. 

 

3. Place the object on window. 

4. A project with one object is now created. 

 



                                                          Create an EasyBuilder Project 

 30 

3.2 Save and Compile the Project 

 

On EasyBuilder Tool Bar: 

 

 

 

 

 

 

 

 

 

 

The languages needed for the project should be set in Label Tag Library in advance. While 

compiling, select the needed languages to be downloaded to HMI. At most 24 languages 

can be selected.    A successfully compiled file will get this dialog box. 

 

1. Click to [Save] *.mtp file. 2. Click to [Compile] to *.xobfile 

for downloading to HMI, this also 

checks if the project can run 

correctly. 
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3.3 Off-line and On-line Simulation 

Off-line simulation - Simulate project operation on PC 

 

On-line simulation - Simulate project operation on PC 

 

 

 

 

 

 

ƴ When On-line simulating on PC, if the control target is a local PLC (i.e. the PLC directly 

connected to PC), there is 10 minutes simulation limit. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Off-line 

 

Click 

On-line 

 

Click after connecting 

the device. 

OK without HMI 

&PLC and save 

more time. 

OK without HMI 

and save more 

time. 

Connect 
PC-PLC & set 
correct 
parameters. 

Simulate 
operations 
without 
connecting PLC. 
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3.4 Download the Project to HMI 

 

< Way 1 [Ethernet] / HMI IP 

 

Before [Download], be sure to check if all the settings are correct. 

 

Set [Password] and 

Specify [HMI IP]. 

 

 

 

 

 

[Runtime (Firmware)] 

Update HMI kernel programs. 

Must do this when first time 

download files to HMI or after 

updating EasyBuilder version. 

 

[Font files] 

Download the font used in project. 

 

[Delete user-defined startup screen] 

[Reset recipe] 

[Reset event log] 

[Reset data sampling] 

The selected files will be erased 

before downloading. 

 

[Reboot HMI after download] 

HMI will reboot after downloading. 
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[Automatically using current settings to download after compiling] 

If this checkbox is selected, the system will download project to HMI according to last 

settings. See illustration below. 

 

 

 

 

 

 

1. Click [Function Properties]. 

2. Select [Automatic save and 

compile when download and simulate]. 

 

 

 

 

 

 

3. [Save] project. 

4. Click [Download]. 

5. Select [Automatically using 

current settings to download 

after compiling]. 

6. Click [Download]. 

7. After finish setting, next time 

when click [Download], 

EasyBuilder will automatically 

compile and download project 

to the latest target HMI. 

 

 

2. Tick 
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< Way 2 [Ethernet] / HMI Name 

 

1. On HMI set HMI name in System Settings. 

 

2. On PC, select the set HMI name and start downloading.

4

. 

Enter the HMI name to search HMI. 

Click to search the HMIs share 

the same network. 
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< Way 3 [USB Cable] 

 

 

 

 

 

Select USB cable to 

download project to 

HMI. The way of 

setting is same as 

Way 1 mentioned 

previously. 

 

 

 

 

 

 

 

 

 

 

ƴ Before downloading via USB cable, please make sure the USB driver is correctly installed. 

Go to [Computer Management] / [Device Manager] to check if USB driver is installed, if 

not, please refer to installation steps to manually install. 

 

 

4

. 

ftp://ftp.weintek.com/MT8000/eng/FAQ/FAQ_29_How_to_install_USB_driver_of_HMI_i_series.pdf
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< Way 4 [USB Disk / SD Card] 

 

1. In Project Manager click 

[Build Download Data 

for CF / SD / USB Disk] 

to build the data to be 

downloaded first. 

Generally divided into 2 

directories, if set as the 

way shown:  

The download data storing 

structure: 

 

2. Insert external devices to HMI.  

3. Select [Download] and enter correct 

password. 

4. Password confirmed, show directories 

in external device.(pccard: SD/CF 

Card usbdisk: USB Disk) 

5. Select a directory for storing project 

then click [OK] to start downloading. 

 

 

 

 

 

 

 

 

 

 

 

ƴ Please select the top layer directory of the target file when downloading. 

For the structure above, select download, not history or mt8000.

4

. 

This directory is 
generated when 
downloading 
history data. 
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Chapter 4 Hardware Settings 
 

4.1 I/O Ports 

 

The I/O ports are different from one HMI type to another.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

In addition, Weintek provides [MT8 ï Multi-Connector Cable] to expand the COM port for 

easier operation. 

 

 
Supports USB devices, such as 
mouse, keyboard, USB disk, printer, 
or barcode device. 

 
Connects to Ethernet devices, such 
as PLC, laptop. 

 
Download / Upload project via SD 
card, including recipe transfer, event 
log, data logéetc and to backup or 
record history data. 

 
Connects PLC or other peripheral 
devices. 
RS-232 / RS-485 2W/4W 
 
 

 

 
Download / Upload project including 
recipe transfer, event log, data 
logéetc. 
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4.2 System Settings 

For the first time operating HMI, please complete the following system settings. When 

finished, the project files designed using EasyBuilder can be used on HMI. 

4.2.1 System Reset 

Each HMI is equipped with a reset button and a DIP switch. When using DIP switch to 

change modes, the 

corresponding functions will 

be triggered. 

If system password is lost or 

forgotten, please flip DIP 

Switch 1 to ON and the rest to 

OFF, and then reboot HMI.  

 

HMI will switch to touch 

screen calibration mode. 

 

 

1. A ñ+ò sign appears on the screen, touch the center 
of the sign, after all 5 signs are touched, ñ+ò 
disappears and the touch screen parameters will be 
stored in HMI system.  
 
 
 
 
 
 
2. After calibration, confirm to restore the default 
password, select [Yes]. 
 
 
 
 
 

 
3. Confirm to restore the default password again by 
typing [yes] and clicking [OK]. The project files and 
history records stored in HMI will all be removed. (The 
default local password is 111111. However, other 
passwords, such as download/upload passwords have 
to be reset.) 
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The above shows the steps to restore factory settings of T and i Series HMI. For X Series, 
users will need a connected USB keyboard, and press any key (or space key) right when 
the first image displayed as HMI power ON to enter the menu. Select "Factory Mode", the 
window mentioned will pop up when system displays project. In case users may miss the 
very first image shown, to press space key continuously since HMI power ON will ensure 
entering the system setting window. 
 
 
 
 
 
 
 
 

 

 

Â Dip Switch 4 is set ON or OFF according to the LCD used. If it should be ON when out 

from factory, the Dip Switch 4 would be set ON and cut off. If it should be OFF, the Dip 

Switch 4 would be set OFF but the switch is not cut. 

4.2.2 System Toolbar 

After rebooting HMI, users can set the system with [System Toolbar] at the bottom of the 

screen. Normally, this bar is hidden automatically. Only by touching the target at the 

bottom-right corner of the screen will the System Toolbar pop up. 

 

 

SW1 SW2 SW3 SW4 Mode 

ON OFF OFF OFF Touch screen calibration mode (X Series excluded) 

OFF ON OFF OFF Hide system toolbar (T Series excluded) 

OFF OFF ON OFF Boot loader mode (X Series excluded) 

OFF OFF OFF ON Enable front panel power switch (X Series only) 

OFF OFF OFF OFF Normal 
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Screen Calibration shortcut, X Series only, for other series, turn SW1 to ON. When X Series 

touch screen drifting problem occurs, please connect an USB mouse to select this mode. 

 

ƴ How to hide HMI System Setting Toolbar 

When [DIP Switch 2] is set ON, the system setting toolbar is disabled. When set OFF; the 

system setting toolbar is enabled. Please restart HMI to enable/disable the toolbar.  

System register [LB-9020] can also enable/disable system setting toolbar 

When [LB-9020] is set ON, the toolbar is displayed, and set OFF to hide the toolbar. 

Note: [LB-9020] is available for all HMI series. [DIP Switch 2] is available for i and X Series. 

4.2.3 System Information 

Network: Displays network information & HMI IP.  Version: Displays HMI system version. 

 

          

 

4.2.4 System Setting 

Set or modify system parameters. 
Confirm password for security. 

 

 

 

 

 

 

ƴ Network 
Download project to HMI via Ethernet. 
Confirm IP address of target HMI. 
[Obtain an IP Address Automatically] or 
[IP address get from below]. 
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ƴ Security 

Password protection, the default is 111111. 

 

 
[Password for entering system]  
[Password for uploading project] 
[Password for downloading project] 
[Password for uploading history data] 
 
Password confirmation dialog: 

 

ƴ Time/Date  
Setting HMI local time/date. 

 
 

ƴ Miscellaneous 
Rotary switch for adjusting LCD brightness.  

 

ƴ History 
Clears history data in HMI. 
[Recipe] / [Eventlog] / [Datalog] 

 

ƴ Firmware setting 
Upgrades firmware / enable portrait mode.  
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ƴ HMI name 

Set HMI name to download/upload project. 

 

 

ƴ VNC server 
Remote HMI monitoring and controlling via 
Ethernet.  

 

Step 1. Enable HMI VNC server, set 

password. 

Step 2. Install Java IE or VNC Viewer on 

PC. 

Step 3-1 Input remote HMI IP in Java IE, 

example: http://192.168.1.28 

Step 3-2 In VNC Viewer input remote HMI 

IP and password. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

One HMI allows only one user to log in VNC 

server at one time. If there is no activity for 

more than one hour, HMI system will log out 

automatically.

http://192.168.1.28/
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4.3 System Setting Editor 

System Setting Editor allows updating hardware system settings by using SD card or 

USB disk. The feature is available for HMI OS version 20141119 or later. The following 

explains how to update HMI IP address by using SD card or USB disk. 

 

1. On EasyBuilder toolbar click [Tools] » [Build Data for USB Disk or CF/SD card 

download], and then select [Use system setting] check box. 

 

2. Click [System Settings] to open System Setting Editor. Specify HMI network 

information as shown in the following figure. 

 

Setting Description 

Import Import and edit an existing .conf file. 

Export Export the configured data to a .conf file. 

Default Restore default. 

 

3. Click [Export] to generate a ñsystemsetting.confò file. 
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4. Click [Exit] to leave System Setting Editor. 

5. Click [Build] button in [USB Disk/CF Card/SD Card Data] dialog box to generate the 

file for download by using SD card or USB disk. 

6. Insert the storage device that stores the download file to HMI and the 

Download/Upload dialog box appears. 

 

Press [Load System setting] and then the [Download Config Settings] message 

appears. The project file will be updated after finishing system settings. 
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Chapter 5 System Parameter Settings 

 

Launch EasyBuilder, in the main menu select [Edit] » [System Parameters] to open the 

[System Parameter Settings] dialog: 

 

 
 

System Parameter Settings are divided into several parts: [Device], [Model], [General], 

[System Setting], [Security], [Font], [Extended Memory], and [Printer/Backup Server]. 

These will be introduced respectively in this chapter. 
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5.1 Device 

 

Parameters in this tab determine the attributes of each device connected with HMI. The 

device can be a Local / Remote HMI / PLC.  

When creating a new project file, there is a default device "Local HMI" which indicates the 

HMI that will be updated and programmed. To change the relevant device settings, click 

[System Parameter Settings] » [Settings] to open [Device Properties] dialog as shown 

below: 
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5.1.1 How to Control a Local PLC 

 
 

ñLocal PLCò means the PLC is connected to the local HMI. To control/connect a Local PLC, 

add this type of device first. Click [System Parameter Settings] » [New] to open [Device 

Properties] dialog as shown below: 

 

For example, we want to connect ñMitsubishi FX0s/FX0n/FX1s/FX1n/FX2ò as a Local PLC: 

 

 

The settings are described below: 

Setting Description 

Name The name of the device. 

HMI / PLC In this example the device used is a PLC, so select [PLC]. 
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Location Select [Local] or [Remote]. In this example the PLC is connected to the 

Local HMI, so select [Local]. 

PLC type Select the type of the PLC. 

PLC I/F The available PLC interface: [RS-232], [RS-485 2W], [RS-485 4W], 

[Ethernet], and [USB]. 

 

If the interface used is [RS-232], [RS-485 2W], or [RS-485 4W], configure 

communication parameters by clicking [Device Properties] » [Settings] 

and then [Com Port Settings] dialog opens, as shown below: 

 

 

[Timeout] 

If the communication has been disconnected for more than preset time limit 

configured in [Timeout] (in sec), Window No. 5 will pop up and show ñPLC 

No Responseò message, as shown below: 

 

[Turn around delay] 

While sending the next command to PLC, HMI will delay the sending 

according to the time interval set in [Turn around delay]. This may 

influence the efficiency of the communication between HMI and PLC. 

Default value is ñ0ò. 

Note: If the PLC used is SIEMENS S7-200 Series, it is recommended to 

assign ñ5ò to [Turn around delay] and ñ30ò to [Send ACK delay]. 
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If the interface used is [Ethernet], click [Device Properties] » [Settings] 

and the [IP Address Settings] dialog opens. Please set correct PLC IP 

address and port number. For example, use a S7-1200 as the connected 

PLC, as shown below: 

 

If the interface is [USB], no further setting is required. Please check the 

settings in [Device Properties]. 

 

If the interface is [CAN (Controller Area Network) Bus], please check the 

PLC connect guide for ñCANopenò and import the eds device file. 

PLC default 

station no. 

The default station number for PLC address if the PLC station number is not 

included in the address, as explained later. 

 

PLC station no. can be set in PLC address. The address format: 

ABC#DEFGH 

ABC stands for PLC station number and ranges from 0 to 255. DEFGH 

stands for PLC address. And the ñ#ò sign separates the station number and 

the address. As shown below, the data is read from PLC station number 1, 

and address T20. 
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Default 

station no. 

use station 

no. variable 

Use the station number variables as the default PLC station number. Select 

one from LW-10000 to LW-10015 as the station number variables. If the 

station no. is not specified in PLC address, the station number will be 

determined by the station no. variable.  

For example, if var7 is set for default station no: 

 

The followings demonstrate some examples: 

a. The PLC station number is ñ5ò. 

 

b. The PLC station number is determined by var7 (LW-10007) 

 

c. PLC address is set to ñ111ò, since PLC station no. is not specified, and 

the default station no. is using var3, the PLC station no. is determined by 

var3 (LW-10003). 

 

Use 

broadcast 

command 

When [Use broadcast command] check box is select, please fill in 

[Broadcast station no.] according to the broadcast station number defined 

by PLC. When HMI sends a broadcast command to the station number set 
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here, PLC will only receive the command and not reply to HMI. 

 
And set as below: 

 

When HMI sends a command to address 255#200, all the PLCs will receive 

this command and will not reply. 

Note: Only PLCs that support broadcast command can use this function. 

Interval of 

block pack 

(words) 

If the interval between read addresses of different commands is less than 

this value, the commands can be combined to one. But the combining 

function is disabled if this value is set to ñ0ò. 

 

For example, the interval value is set to ñ5ò, to read 1 word from LW3 and 2 

words from LW6 respectively (read from LW6 to LW7), since the interval of 

addresses between LW3 and LW6 is less than 5, these two commands can 

be combined to one. The result is to read 5 consecutive words from LW3 to 

LW7. 

Note: The maximum size of command combination data must be less than 

[Max. read-command size]. 

Max. read -  
command 
size 
(words) 

The maximum data size to read from the device at one time. Unit: word 

Max. write - 
command 
size 
(words) 

The maximum data size to write to the device at one time. Unit: word. 

 

After all settings are completed, a new device named ñLocal PLC 1ò is added to the [Device 

list]. 
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5.1.2 How to Control a Remote PLC 

  

ñRemote PLCò is a PLC being connected to a remote HMI. To control a remote PLC, add this 

type of device first. Please click [System Parameter Settings] » [New] to open [Device 

Properties] dialog. For example, use SIEMENS S7-200 as the Remote PLC: 
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The settings are described below: 

Setting Description 

HMI or PLC In this example, the device used is a PLC, so select [PLC]. 

Location Select [Local] or [Remote]. In this example the PLC is connected to 

Remote HMI, so select [Remote]. Set the IP address and port number of 

the Remote HMI by clicking [Settings] next to [Remote]. 

 

PLC Type Select the type of the PLC. 

PLC I/F The interface used for Remote PLC. If the remote PLC uses a COM port, 

select [RS-232], [RS-485 2W], or [RS485 4W]. 

PLC 

default 

station 

no. 

Set the station number of Remote PLC. 

COM Set the COM port used by the Remote PLC, this setting must be correct. 

 

After all settings are completed, a new device named ñRemote PLCò is added to the [Device 

list]. 
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5.1.3 How to Control a Remote HMI 

 

          

 

ñRemote HMIò is the HMI other than ñLocal HMIò, and PC is also a ñRemote HMIò. To control 

a Remote HMI, add this type of device first. Click [System Parameter Settings] » [New] to 

open [Device Properties] dialog as shown below: 
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Setting Description 

HMI or PLC In this example, the device used is a HMI, so select [HMI]. 

Location Select [Local] or [Remote]. In this example Remote HMI is used, select 

[Remote]. Set the IP address and port number of the Remote HMI by 

clicking [Device Properties] » [Settings]. 

 

 

After all settings are completed, a new device named ñDeviceò with ñNo.ò as ñRemote HMI 1ò 

is added to the [Device list]. 
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5.2 Model 

Configure the [HMI model], [Timer], [Printer] and [Scroll bar] settings. 

 

The settings are described below: 

 

Setting Description 

HMI model Select the HMI model to use. 

 

If the HMI model is changed, the [Resize pop-up windows / objects] 

dialog will pop up, as shown below. Select required adjustment and 

click [OK]. In most cases, please select all options. 
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HMI station 

no. 

Set the station number of current HMI. The default value is ñ0ò. 

Port no. Set the port number of current HMI. It is also used in MODBUS TCP 

server. The default value is ñ8000ò. 

Timer [Clock source] 

Set the source device of the clock/time information. It is used by [Data 

Sampling], [Event Log], é., etc.  

a. If [HMI RTC] is selected, the time information comes from the 

internal clock of the HMI. 

b. If [External device] is selected, the time information comes from 

an external device. The address of the source device must set 

correctly. As shown below, the time information is from ñTVò 

address type of the ñLocal PLCò. The addresses of ñTVò start from 0 

and contain 6 consecutive words and each of them store the 

following information: 

TV 0 Ÿ  Second (range: 0~59) 

TV 1 Ÿ  Minute (range: 0~59) 

TV 2 Ÿ  Hour (range: 0~23) 

TV 3 Ÿ  Day (range: 1~31) 

TV 4 Ÿ  Month (range: 1~12) 

TV 5 Ÿ  Year (range: 1970~2037) 
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Printer [Type] 

A printer can be connected with the HMI. For HP PCL Series, it has to 

be connected through USB interface while other printers through a 

COM port. For more information, please refer to ñChapter 23 HMI 

Supported Printersò. 

 

If the printer is connected through [COM], configure the parameters 

correctly. If the printer type is [SP-M, D, E, F], the [pixels of width] 

has to be set accurately, i.e. the set pixel(s) cannot exceed printerôs 

default setting, or the HMI will fail to print data. 

 

Scroll bar [Width] 

Set to [Small], [Middle] or [Large] as required.  

Set the width of Scroll Bar, when the size of the object is too small to 

display the contents, a scroll bar is displayed in the object. 
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Store library 

to the same 

directory as 

project 

 

When this feature is enabled, the Shape Library / Picture Library / 

Sound Library / Macro Function Library will be saved to the Library 

folder under the same directory as the project file as shown in the 

following figure. 
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5.3 General 

 

Configure the properties related to screen display. 
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The settings are described below: 

Setting Description 

Fast 

selection 

button 

Setting the attributes for fast selection button for Window No. 3. To use 

the fast selection button, create Window No. 3 first. 

a. [Attribute] 

 

Enable or disable fast selection window. Select [Enable] and click 

[Settings] to set the attributes, including color and text of the button. 

b. [Position] 

 

Select the button position on the screen. If [Left] is chosen, the button 

will show up in at bottom left side of the screen; if [Right] is chosen, the 

button will show at the bottom right side of the screen 

Screen 

saver 

a. [Back light saver] 

If the screen is left untouched and reaches the time limit set here, the 

back light will be turned off. The unit is minute. Back light will be on again 

once the screen is touched. If [none] is set, the back light will always be 

on. 

b. [Screen saver] 

If the screen is left untouched and reaches the time limit set here. The 

current screen will automatically switch to a window assigned in [Saver 

window no.].The setting unit is minute. If [none] is set, this function is 

disabled. 

c. [Saver window no.] 

To assign a window for screen saver. 

Option a. [Startup window no.] 

Designate the window shown when start up HMI. 

b. [Common window] 

 

The objects in the common window (Window No. 4) will be shown in 

each base window. This determines that the objects in common window 
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are placed above or below the objects in the base window. 

c. [Keyboard caret color] 

Set the color of caret that appears when entering data in [Numeric Input] 

and [Word Input] objects. 

d. [Object layout] 

 

If [Control] mode is selected, when operating HMI, [Animation] and 

[Moving Shape] objects will be displayed above other kinds of objects 

neglecting the sequence that the objects are created. If [Nature] mode is 

selected, the display will follow the sequence that the objects are 

created, the first created will be displayed first. 

e. [RW_A enabled] 

Enable or disable recipe data RW_A. Enable this, the objects can then 

control RW_A .The size of RW_A is 64K. 

Event [Extra no. of events] 

The default number of the events in the system is 1000. For additional 

number of events, modify this setting. The maximal is 10000. 

Keyboard The window number in which the keyboard is placed. When using 

[Numeric Input] or [ASCII Input] objects, the type of keyboards can be 

selected. Up to 32 keyboards can be added. To design a keyboard, a 

window should be designated for creating it. Press [add] after creating, 

and add the window to the list. For more information, please see 

ñChapter 12 Key Pad Design and Usageò  

Project 

protection (i 

series only) 

Userôs project can be restrained and executed on specific HMI (only for i 

series HMI). Please refer to ñChapter 30 Project protectionò for more 

information. 
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5.4 System Setting 

 

[System Setting] is used to configure different functions of EasyBuilder. 

 

 

Some functions are duplicated from system registers, such as, [Hide system setting bar 

(LB-9020)], [Hide mouse cursor (LB-9018)], [Disable buzzer (LB-9019)], [Prohibit remote 

HMI connecting to this machine (LB-9044)], and [Disable upload function (LB-9033)]. Users 

can also set these functions via system tag.  
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To select a system tag, select [Address] » [System tag] check box when adding a new 

object and then select the [Device Type].  

To browse all the system tags, Select [Library] » [Tag] » [System] from the main menu of 

EasyBuilder. 

[Startup language after redownloading the project] 

Set the language to use when HMI starts after the project is re-downloaded. 

[Execute init. MACRO when power on] 

Designate the macro to be executed when HMI power on. 

[Auto logout] 

If leaving HMI untouched for longer than the set time, the objects protected by security 

classes will not be able to operate. The user ID and password must be entered again to 

unlock it. 

[Hide System Setting Bar] 

Hide the system setting bar in the bottom right corner of the HMI screen.  

[Hide Mouse Cursor] 

Hide the mouse cursor in HMI screen. 

[Disable Buzzer] 

Mute HMI. 

[Prohibit remote HMI connecting to this machine] 

Prohibit the connection with a remote HMI. The remote HMI will not be able to control the 

local HMI. 

[Disable upload function (effective after rebooting HMI) (or set LB9033 ON)] 

Disable HMI to upload project, after downloading, HMI must be rebooted to disable 

uploading project. 

[Prohibit password remote-read operation (or set LB9053 ON)] 

Prohibit Remote HMI to read Local HMI password. 

[Prohibit password remote-write operation (or set LB9054 ON)] 

Prohibit Remote HMI to write Local HMI password. 

[Use a disconnection icon or relative objects when PLC communication fails] 

Decide whether or not to display a disconnection icon on relevant objects when failing to 

communicate with PLC. 

 

When using this function and fail to communicate with PLC, this icon will be shown in the 

lower right corner of the object as below: 
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[VNC Server] 

Set the password to log in VNC server. 

 

[LW protection], [RW protection] 

If select [Disable LW/RW remote-write] check boxes and set the protect range in [LW/RW 

range], values within the protected range cannot be adjusted using Remote HMI. 

 

[Easy Access server] 

Through this technology, users can easily access to any HMI connected to the internet and 

operate them on PC just like holding touch screen in hand.  

Easy Access does not transmit updated graphic images directly but only the real time data. 

This makes transmission really quick and efficient. Please refer to ñEasyAccess Manualò for 

more information. 
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5.5 Security 

 

Parameters in this tab configure the user passwords and security classes.  

 

5.5.1 Select operatable classes for each user 

 

 

Up to 12 sets of user and password are available. Password should be one non-negative 

integer. Once the password is entered, the objects that the user can operate are classified. 

There are six security classes available: A to F. 

If [None] is selected for an object, every user can access this object. 

 

For example, when the security class of User1 is set as below, User1 could only access 

objects of classes A, B, C and ñnoneò. For more information, please refer to ñChapter 10 

Securityò. 
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[Project password (MTP file)] 

 

 

 

Users can set password to protect the project (mtp) files. The password set here must be 

entered when editing the project file.  

 

Select [Enable] then click [Setting], and the dialog below opens. 

 

Before editing a project, a popup window is shown for entering the password. Only when the 

password is correct can the user edit this project. 
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5.6 Font 

 

Parameters in this tab determine the non-ASCII fonts. 

 

[Fonts for non- ascii strings] 

The non-ASCII fonts are listed above. When using non-ASCII characters or double byte 

characters (including Simplified or Traditional Chinese, Japanese, or Korean) which are not 

listed in [Fonts for non-ascii strings] table, EasyBuilder will select a font from the list to 

substitute for it automatically. 

The non-ASCII fonts in Windows can be added to the [Fonts for non-ascii strings] table. 

[Line spacing] 

Decide the space between lines in the text. 

[Support Arabic, Persian, Hebrew, and Thai, éalphabets] 

Select this check box to correctly display Arabic, Persian, Hebrew, and Thai alphabets. 
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5.7 Extended Memory 

 

Parameters in this tab determine the location of the extended memory. 

 

 

 

Extended Memory is numbered from EM0 to EM9. It works in a way similar to other device 

types (i.e. LW or RW address). Users can simply select from [Device type] list while adding 

a new object. Size of each extended memory is up to 2G word. 
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Extended memories are saved as files in [SD card] or [USB disk]. [EM0] to [EM9] are 

saved as ñem0.emiò to ñem9.emiò respectively. Users can use RecipeEditor.exe to open 

these files and edit the data in the extended memory. 

 

Data in extended memory will not be erased when power is cut, which means next time 

when start up HMI again, data in the extended memory remains the same as before power 

off. This is similar to recipe data (RW, RW_A). The difference is that users can specify the 

location to store data. (SD card, USB disk) 

 

When the device of extended memory does not exist and to read data in it, the data content 

will be ñ0ò; to write data to a device that does not exist, the "PLC no response" message will 

be shown in HMI. 

 

HMI supports "Hot Swapping" function for SD card and USB devices. Users can insert or 

remove the device for extended memory without cutting the power. With this function, users 

can update or take data in extended memory. 
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5.8 Printer/Backup Server 

 

Configure remote printer / backup server. 

 

 

The settings are described below: 

 

Setting Description 

Output settings [Orientation] 

Set how will words or pictures be printed out, [horizontal] or 

[vertical]. 

[Printer size] 

Set to print out in [Original size] or to [Fit to printer margins]. 

[Margin] 

Set the top, bottom, right and left margin width. 

Communication 

settings 

 

[IP address] 

Assign the IP address of the printer via network. 

[Port], [User name], [Password] 
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Specify the data to log in printer.  

Port can be set from 1 to 65535. 

Maximum length of user name or password is 12 characters. 

Please refer ñChapter 26 EasyPrinterò for more information. 
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Chapter 6 Window Operations 
 

A window is a basic element in a project. With a window, all kinds of information like objects, 

pictures, and texts can be displayed on HMI screen. Total 1997 windows numbered from 3 ~ 

1999 in EasyBuilder can be built and edited. 

 

6.1 Window Types 

 

There are 4 types of windows, each with different functions and usages: 

(1) Base Window (2) Fast Selection Window (3) Common Window  

(4) System Message Window 

 

6.1.1 Base Window 

 

The most frequently used window, except for main screen, it can also be: 

ƴ A background of other windows. 

ƴ A keyboard window. 

ƴ A pop-up window of [function key] object. 

ƴ A pop-up window of [direct window] and [indirect window] objects. 

ƴ A screen saver. 

 

 

ƴ Base Window should be in same size as the HMI screen. Therefore, the resolution of the 

base window should set to the resolution of HMI. 

 

6.1.2 Fast Selection Window 

 

Window no. 3 is the default Fast Selection Window. This window can co-exist with base 

window. Generally, it is used to place the frequently-used buttons on the lower-left side or 

the lower-right side on the screen. Please create window no. 3 first, and set the relevant 

properties in [System Parameter Settings] » [General] tab. Apart from showing or hiding 

fast selection window with the button on the screen, there are system registers to do so: 
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[LB-9013] FS window control [hide(ON)/show(OFF)] 

[LB-9014] FS button control [hide(ON)/show(OFF)] 

[LB-9015] FS window/button control [hide(ON)/show(OFF)] 

6.1.3 Common Window 

 

Window no. 4 is the default Common Window. Objects in this window will be displayed in 

other base windows, not including popup windows. Therefore, the common objects in 

different windows are often placed in common window. 

 

When operating HMI, select [Function Key] » [Change common window] to change the 

source of common window. 

 

In menu [Option] » [Function 

Properties] select whether or not 

to [Display Common Window 

objects on Base Windows] when 

editing a project. This can avoid 

overlapping objects in base 

window with objects in common 

window. 

 

 

6.1.4 System Message Window 

 

Windows No. 5, 6, 7, 8 are the default System Message Windows: 

 

[Window No. 5: PLC Response] 

When the communication between PLC 

and HMI is disconnected, this message 

window will pop up automatically right on 

the base window currently opened. 
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ƴ ñPLC no responseò window can be disabled by system registers. 

Please refer to ñChapter 22 System Reserved Words & Bitsò for more information. 

 

[Window No. 6: HMI Connection] 

When failing to connect HMI with a 

remote HMI, this message window will 

pop up automatically. 

 

[Window No. 7: Password Restriction] 

When attempting to control 

an object without 

authorization, this window 

may pop up as a warning 

depending on the settings 

of the object. 

 

[Window No.8: Storage Space Insufficient] 

When HMI flash memory, USB disk or SD card run 

out of storage space, this message window will pop 

up automatically. (When the memory space is under 

4 MB) 

The following system registers can be used to check the free memory space in HMI, USB 

disk, or SD card: 

[LW-9072] HMI current free space (K bytes) 

[LW-9074] SD current free space (K bytes) 

[LW-9076] USB 1 current free space (K bytes) 

[LW-9078] USB 2 current free space (K bytes) 

To check if there is sufficient storage in the devices, the following system registers can be 

used. These addresses will set ON when the space is under 4 MB. 

[LB-9035] HMI free space insufficiency alarm (when ON) 

[LB-9036] SD card free space insufficiency alarm (when ON) 

[LB-9037] USB 1 free space insufficiency alarm (when ON) 

[LB-9038] USB 2 free space insufficiency alarm (when ON) 

 

The text shown in windows no. 5 ~ 8 can be edited for easier reference. 
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20B 

Â A screen can display up to 16 popup windows simultaneous including System Message 

Window, Direct Window and Indirect Window. 

Â The system does not allow opening the same window with two Direct (or Indirect) 

Windows in one base window. 

Â Windows no. 3 to 9 are used by the system only, and windows no. 10 to 1999 can be 

edited based on actual usage. 

 

6.2 Create, Set, and Delete a Window 

 

Check the existing windows in [View] » [Window Tree]. 

 

[Object list] displays window numbers and window names. Opened windows are marked 

with (*) sign. Press the (+) sign to see the object ID, address and description in this window. 

[Window preview] displays the 

thumbnails of windows. 

6.2.1 Creating and Setting a Window 

 

In window tree right click on a window 

number then select [New]. 
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[Name] The name will appear on the title bar and also in window tree. 
 
[Window no.] can be 3 to 1999 
 
[Size] Set the window size in accordance with the HMI resolution. 
 
[Underlay window] [Popup window] 
Please refer to the description below. 
 
 
 
 
 
 
[Underlay window] 

Underlay Window can be seen as an extra Common Window. When designing the project, 

the often used objects may be placed in different windows but not all windows. These 

objects can be placed in underlay window. 

Each base window can set three underlay windows as background, from [Bottom] to [Top]. 

The objects in underlay windows are displayed in this order in base window. 

 

[Popup window] 

Base window can also be used as a pop-up window. Use [X] and [Y] to set the coordinates 

indicating where in the screen will this base window pop up. The origin of the coordinates is 

the upper-left corner of the window. 

 

[Monopoly] 

If the option is selected, when the base window pops up, no operations of other popup 

windows and background windows are allowed until the monopoly window is closed. If a 

base window is used as a keyboard window, ñMonopoly" is automatically enabled. 

 

 

ƴ The objects in underlay window cannot be edited from the base window that displays them. 

To edit those objects, please open the underlay window where they are located. 

ƴ When the window number of the underlay window used by the base window is identical to 

the popup window, the popup window is disabled. 

ƴ When base window and popup window use the same underlay window, the objects in the 

underlay window cannot be displayed in popup window. 
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[Window] » [Open Window]  

Click [New] and select the type of the window and click [OK]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The way to call up [Window Settings] dialog: 

 

ƴ Right click on the window number in the window tree and select [Settings]. 

 

ƴ In [Window] » [Open Window] select the window then click [Settings].  

ƴ In the window, right click when no object is selected, and select [Attribute]. 
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6.2.2 Open, Close and Delete a Window 

 

Open an existing window: 

ƴ Double click on the window number in the window tree. 

ƴ In the window tree, select the window, right click, then select [Open]. 

ƴ In [Window] » [Open Window] select the window then click [Open]. 

 

Close or delete an existing window: 

ƴ In the window tree, select the window; right click, then select [Close] or [Delete]. 

ƴ In [Window] » [Open Window] select the window then click [Delete]. 

To delete a window, please close it first. 
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Chapter 7 Event Log 

 

7.1 Event Log Management 

 

               

 

 

 

 

 

 Alarm Bar / Alarm Display / Event Display 

Using these objects to view the process of 
the whole event from triggeringʤwaiting to 
be processedʤreturn to normal. Define the 
event content first. 
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The settings are described below: 

 

[Category] 

Classifies events by dividing them into 0 ~ 255 categories. Select one category to add or 

view event log. In the bracket ñ[ ]ò, it shows how many events are in this category. 

 

[History files] 

To specify the storage location of an event log. However, when executing On-line or Off-line 

Simulation on PC, the files will be saved in the HMI_memory / SD_card / USB folder under 

the installation directory. 

 

[Preservation limit] 

This setting determines how many days the data is preserved. For example, the [Days of 

preservation] is set to two days; the data of yesterday and the day before yesterday will be 

kept. Data that is built before this period will be deleted automatically to prevent the storage 

space from running out. 

 

[Print] 

In [System Parameter Settings] » [Model], select a printer. The printing format can then be 

set. 

 

[Paste] 

Overwrites the selected item with the new items. A message window will pop up to confirm 

this operation. 

 

[Paste (Add Mode)] 

Appends as a new entry. 
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7.1.1 Excel Editing 

 

Click on the Excel icon in Event Log setting dialog to open the Excel template for a reference 

of editing. 

This template is under the installation directory, the file name is EventLogExample.xls. This 

template includes the ready-made dropdown lists and validation mechanism. 

 

 

 

 

1. [System tag] and [User-defined tag] cannot set to true simultaneously, otherwise, the 

system will view the User-defined tag to be a System tag, and [User-defined tag] to be 

false. If setting [Device type] to [User-defined tag], please set [System tag] to false. 

2. [Color] format is R:G:B, each should be an integer form 0 to 255. 

3. When setting [User-defined tag] to true, if the system compares the [Device type] with 

the user-defined tag in the system, and no suitable tag is found, the system will set the 

[User-defined tag] in event log to false. 

4. Before importing Label Library / Sound Library, please make sure the library names 

exist in the system. 



                                                                          Event Log 

                                                                                         84 

 

7.2 Create a New Event Log 

7.2.1 Event (Alarm) Log General Settings 

Click [New] in the [Event (Alarm) Log] dialog, the dialog below appears. Select [General] 
tab. 

 

[Category]  

Select event category, 0 ~ 255. 
 
[Priority level] 
When the number of events equals to the max number available in the system (default 1000), 
the lower priority events will be deleted and new events will be added in. 
 
[Read address] 
System reads data from this address to check if the event matches the trigger condition. 
 
[Notification] 
When enabled, the system will set the specified address ON or OFF when the event is 
triggered. 
 
[Condition] 
When [Bit] is selected, Event Log will detect the state of a Bit address. 
When [Word] is selected, Event Log will detect the value of a Word address to check if it is 
greater than, less than, or equals to a specified value. 
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The setting above indicates: 

When [Read address] value is greater than or equals to 29 (= 30 - 1)  

Or less than or equals to 31 (= 30 + 1), the event will be triggered. The trigger condition: 

 

29 Ò [Read address] value Ò 31 

 

After the event is triggered, when [Read address] value is greater than 32 (= 30 + 2) or less 

than 28 (= 30 - 2) the system will return to normal condition: 

  

[Read address] value < 28 or [Read address] value > 32 

 

 

 

The setting above indicates: 

When [Read address] value is less than 29 (= 30 - 1) 

or greater than 31 (= 30 + 1), the event will be triggered. The trigger condition: 

 

[Read address] value < 29 or [Read address] value > 31 

 

After the event is triggered, when [Read address] value is greater than or equals to 28 (= 30 

- 2) or less than or equals to 32 (= 30 + 2) the system will return to normal condition: 

 

28 Ò [Read address] value Ò 32 
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7.2.2 Event (Alarm) Log Message Settings 

Select [Message] tab: 

 

The settings are described below: 

[Content] 

The text content displayed in [Alarm Bar], [Alarm Display], and [Event Display] objects. Use 

the formats in the following two examples or WATCH addresses to use register data in 

content. 

 

 

The data of the LW register can be used in the content displayed when an event is triggered: 

Format: %#d (% -> initial sign, # -> address, d -> end sign) 

When an event is triggered, if the value in LW-20 is 13: 

Setting: ñHigh Temperature = %20dòŸ Display: ñHigh Temperature = 13ò 
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The data in the specified address when the event is triggered can be included in the content 

displayed. The address should be set to the [Read address] of Event Log, take MODBUS 

RTU 4x address as an example: 

Format: $#d ($ -> initial sign, # -> address, d -> end sign) 

When an event is triggered, if the value in MODBUS 4x-15 is 42: 

Setting: ñHigh Temperature = $15dò Ÿ Display: ñHigh Temperature = 42ò 

 

[Font] / [Color] 

The font and color can be set differently for each event. The setting determines the font and 

color shown in [Alarm Bar], [Alarm Display] or [Event Display] objects. 

 

[Write value for Event/Alarm Display object] 

When an event in [Event Display] or [Alarm Display] is acknowledged, the value is written to 

the assigned [Write address]. 

 

[Sound] 

 

 

If enabled, the selected sound will be played when an event is triggered. Continuous beep 

can also be enabled, which only stops when the event is acknowledged or recovered. 

For continuous beep, a delay time can be set between triggering the alarm and the start of 

beeping. 

 

[Address of WATCH 1 ~ WATCH 8] 

Click [Syntax] to edit and display the value in watch address when the event is triggered. Up 

to 8 watch addresses can be set. 
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Chapter 8 Data Sampling 

 

 

 

 

 

 

 

 

8.1 Data Sampling Management 

Create a new Data Sampling object first by the following steps: 

1. From the menu select [Objects] and click on [Data Sampling]. 

2. Click [New] to finish relevant settings: 

 

 

Define how the 
data is sampled  
1. sampling time 
2. address 
3. data length 

Save the sampled 
data to the 
designated 
location, such as 
HMI, SD card, 
USB disk. 

Use [Trend Display] 
and [History Data 
Display] objects to 
display sampling 

records. 
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8.2 Create a New Data Sampling 

The following introduces how to add a new Data Sampling: 

 

1. [Sampling mode] 

Â [Time-based] mode samples data in a fixed frequency. The [Sampling time interval] 

can be set from ñ0.1 second(s) to 120 minsò. 

Â [Trigger-based] mode triggers data sampling by the status of a designated address. 

[Mode] 

Conditions to trigger Data Sampling: 

[OFF -> ON] Trigger sampling when the status of the address changes from OFF to ON. 

[ON -> OFF] Trigger sampling when the status of the address changes from ON to OFF. 

[OFF <-> ON] Trigger sampling when the status of the address changes. 

[Set ON/OFF after triggered] 

If selected, after triggering Data Sampling, the system will set the designated bit address 

back to ON/OFF state. 

 

2. [Read address]  

Specify an address to be the source of Data Sampling. 

 

3. [Data Record]  

The max. number of data records can be saved by one Data Sampling in one day is 86400. 

(1 record per second for 24hours) If [sampling time interval] is set to ñ0.1 secondò, the max. 

number of data records is still 86400.  

 

1. 

2. 

3. 

4. 

5. 

6. 
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[Data Format] 

Available to read several data in different format. 

 

[Auto. stop] 

This function depends on the arrangement of different objects and modes. (Set [Max. data 

records] to n.)  

 

The figure illustrates how the data is sampled in Trend Display ï Real Time mode when 

Auto. stop check box is not selected. 

 

As shown in the preceding figure, if Data length is set to 10, when the 11th data is generated, 

the oldest data is deleted, and the newest data is added. 

Objects not selecting [Auto. stop] 
 
selecting [Auto. stop] 
 

Trend Display - Real Time 

Deletes the earlier records 
and displays the latest 
number of records (n) in 
Trend Display. Please refer 
to the following figure. 

Stops after reaching the 
specified number of data 
records (n). 

Trend Display - Historical 
Keeps on sampling data and 
displays all history data in 
Trend Display. 

Stops after reaching the 
specified number of data 
records (n). 

History Data Display 

Keeps on sampling data and 
displays all history data in 
History Data Display. 

Stops after reaching the 
specified number of data 
records (n). 

Data Sampling 

Keeps on sampling new 
data. 

Stops sampling after 
reaching the specified 
number of data records (n). 
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Â A Data Sampling may include more than one type of records. Data Sampling can 

retrieve different types of records at the same time. For example, user defines three 

types of data, 4 words in total. In this way, system retrieves a 4-word data each time 

from the designated address to be the content in one Data Sampling. 

Â When running simulation and save data sampling records, to change the data format, 

be sure to delete the previous data records in the installation directory to avoid the 

system to read the old data records. 

 

4. [Clear address] 

Set when the bit address status changes from [OFF -> ON] or [ON -> OFF], clear the 

sampled data in Trend Display Real-time Mode. The number of data records returns zero 

but the data records that are already saved will not be cleared. 

 

5. [Hold address] 

If the status of the designated address is set ON or OFF, sampling will be paused until the 

status of the designated address returns. 

 

6. [History files]  

[Save to HMI momery] 

Save Data Sampling to HMI only when its size reaches 4kb. Or, use system register 

[LB-9034] to force storing data. 

[Save to SD card / USB 1 / USB 2] 

Save Data Sampling to the specified external device. 

[Folder name] 

Specify Data Sampling file name which must be all in ASCII characters. 

The folder name will be written as: [Storage Location] \ [Folder Name] \ yyyymmdd.dtl 

The files are saved in the specified folder according to the date the file is generated. 

 

As shown in the following figure, the files are saved in the Test folder according to date. 
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[Preservation limit] 

This determines how many days the data is to be preserved. 

 

 

Â If [Preservation limit] is set to 2 days, the data of yesterday and the day before 

yesterday will be kept. Data that is not built in this period will be deleted to prevent the 

storage space from running out. EX: if today were July 1st, data of June 30th and June 

29th will be preserved and data of June 28th be deleted. 

Â When running simulation on PC, all data sampling will be saved to the datalog folder in 

the storage location. 
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Chapter 9 Object General Properties 

 

The setting of general properties of an object includes: 

 

1. Selecting the PLC. 

2. Setting read and write address 

3. Using Shape Library and Picture Library 

4. Setting label text 

5. Adjusting profile size 

 

9.1 Selecting the PLC 

 

Some objects are for controlling PLCs. As shown, [PLC name] represents the PLC to 

control. In this example there are two devices: ñLocal HMIò and ñMitsubishi 

FX0s/FX0n/FX1s/FX1n/FX2.ò The listed available devices come from [System Parameters 

Settings] » [Device List] 

 

 

 

9.1.1 Setting Read and Write Address 
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The settings of read and write address: 

 

[PLC name] 

Select the PLC type. 

 

[Device type] 

Different PLC has different device type. 

 

 

 

[Address] 

Set the read and write address. 

 

[System tag] 

Address tags include ñsystem tagò and ñuser-defined tag.ò Click [Settingé] beside [PLC 

name] and select [system tag] check box. This allows users to use the preserved 

addresses by system for particular purpose. 

The address tags are divided into bit or word (LB or LW).  

After selecting [System tag], not only will the [Device type] displays the chosen tag, 

[Address] will also display the chosen tag as shown below.  
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The illustration below shows a part of system tags. For more information, please refer to 

ñChapter 16 Address Tag Libraryò and ñChapter 22 System Reserved Words and Bitsò. 

 

 

 

[Index register] 

Select this check box to use the index register, please refer to ñChapter 11 Index Registerò 

for more information. 

 

Selecting Data Type 

EasyBuilder supports data types that are listed below. Selecting correct data type is 

necessary especially when using address tag. 
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9.2 Using Shape Library and Picture Library 

 

Shape Library and Picture Library are used for adding visual effect on objects. Select 

[Shape] tab when creating an object to use the libraries: 
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9.2.1 Settings of Shape Library 

[Shape Libraryé] 

Select [Use shape] check box to select a shape from the library.  

 

[Inner] 

Select this check box to set the inner part of a shape. Click the drop down button to select a 

color or customize a color and click [Add to Custom Colors]. EasyBuilder will save this 

color. 

 

 

 

[Frame] 

Select this check box to set the frame of a shape. Click the drop down button to select a 

color. 

 

[Interior Pattern] 

Set the color of the interior pattern of the shape.  

 

[Pattern Style] 

Click this button to select a pattern. 
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[Duplicate these attributes to every state] 

Duplicate all attributes of the current state to the other states. 

 

How to set [Shape Libraryé] 

Click [Shape Libraryé] button. The currently selected shape is marked by a red frame. 
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The illustration above provides information of one of the Shapes in the Shape Library as 

follows: 

 

2: Green The number and the name of the shape. 

States: 3 The number of the states of the shape.  

Frame Indicates that the Shape only has a frame. 

  

The illustration below shows that the Shape has ñinnerò and ñframe.ò 

 

 

  

Please refer to ñChapter 14 Shape Library and Picture Libraryò for more details. 

 

When finished, click [OK] and preview the design of the shape.   
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9.2.2 Settings of Picture Library 

 

[Picture Library] 

Select [Use picture] check box to select a shape from the library. 

 

How to set [Picture Libraryé] 

Click [Picture Libraryé] button. The currently selected picture is marked by a red frame. 
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The illustration above provides information of one of the Pictures in the Picture Library as 

follows: 

 

0 : PB Red The number and the name of the Picture 

States: 2 The number of the states of the Picture 

30054 bytes The size of the Picture 

BMP 

(100x100) 

The format and resolution of the Picture; *.bmp means bitmap picture. The 

format can also be *.jpg, *.png, *.dpd, or *.gif. Picture length: 100 pixels 

and height: 100 pixels. 

     

Please refer to ñChapter 14 Shape Library and Picture Libraryò for more details. 

 

When finished, click [OK] and preview the design of the picture. 
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9.3 Setting Label Text 

 

Select [Label] tab when creating an object to use the libraries: 

 

 

 

[Use label] 

Select this check box to use a label for the object. EasyBuilder supports Windows true-font. 
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[Use label library] 

Select this check box to choose a label in Label Library. 

 

 

[Label Libraryé] 

Please refer to ñChapter 15 Label Library and Multi-Language Usageò for more details. 

 

[Font] 

Select a font from the list. EasyBuilder supports Windows true-font. 

 

 

[Color] 

Select the font color. 

 

[Size] 

Select the font size.  

 

[Align] 

Align the multiple lines of the text. 

 

.  

 

The text aligned [Left]. 
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The text aligned [Center]. 

 

 

The text aligned [Right]. 

 

 

 

[Blink] 

Specify the way the text blinks:  

Choose [None] to disable this feature or set the blinking interval to [1 second] or [0.5 

seconds]. 

 

 

[Italic] 

Use Italic font. 

 

 

[Underline] 

Use Underline font. 

 

 

[Movement] setting 

[Direction] 

Set the direction of the marquee effect. 
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[Continuous] 

Specify how the marquee effect is displayed: 

 

 

 

If not selecting this check box, the next text appears only when the previous text disappears 

completely. See the picture below. 

 

  

 

 

If selecting this check box, the text will be displayed continuously. 

 

 

 

[Speed] 

Adjust the speed of the text movement. 

 

[Content] 

Set the content of the text. If using [Label Library], the content comes from Label Library. 

 

[Tracking] 

If this check box is selected, changing the text of one state will also change the text of the 

other states. 

 

[Duplicate this label to other states] 

Duplicate the current text to the other states. 
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9.4 Adjusting Profile Size 

 

When an object is created, double click it and select the [Profile] tab to adjust the position 

and size of the object. 

 

 

 

Position 

[Pinned] When this check box is selected, the position and the size of the object cannot be 

changed.  

[X] and [Y] are coordinates of the left-top corner of the object. 

 

Size 

Adjust the [width] and [height] of the object. 
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9.5 Variables of Station Number 

 

EasyBuilder allows users to set the variables of station number in PLC address. As shown 

below, ñvar2ò is one of 16 station number variables. 

 

 

 

The syntax of the variable of a station number: varN#address 

 

The range of N is integer from 0~15; address means PLC address. 

16 variables are availble var0 ~ var15. These variables of station number read values from 

address LW-10000~LW-10015. The list below shows the variables and the corresponding 

system reserved addresses  

  

var0   LW-10000 

 var1   LW-10001 

var2   LW-10002 

 var3   LW-10003 

var4   LW-10004 

 var5   LW-10005 

var6   LW-10006 

 var7   LW-10007 

var8   LW-10008 

var9   LW-10009 

var10   LW-10010 

 var11   LW-10011 

var12   LW-10012 

 var13   LW-10013 

var14   LW-10014 

 var15   LW-10015 

 

For example, ñvar0ò reads value from LW-10000, when the value in LW-10000 is ñ32ò, 

var0#234 = 32#234, the station number is 32.  

Similarly, ñvar13ò reads value from LW-10013, when the value in LW10013 isò 5ò, var13#234 

= 5#234. 
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9.6 Broadcast Station Number 

 

HMI provides two ways for users to enable broadcast command. First is to set the PLC 

parameter directly in [system parameter settings]: 

 

 

 

The second way is to use system tag to enable or disable broadcast station number or to 

change it.  

The corresponding system tags are listed below: 

 

LB-9065  disable/enable COM 1 broadcast station no. 

LB-9066  disable/enable COM 2 broadcast station no. 

LB-9067  disable/enable COM 3 broadcast station no. 

 

LW-9565 COM 1 broadcast station no. 

LW-9566 COM 2 broadcast station no. 

LW-9567 COM 3 broadcast station no. 
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Chapter 10 User Password and Object Security 

This chapter discusses the protection for 

operations provided by setting up user 

passwords and security classes.  

 

To set up the protection system, please:  

1. Set user password and operable 

classes. 

2. Set object class for objects. 

An object belongs only to one security class. Setting the object class to ñNoneò means any 

user can operate this object. 

10.1 User Password and Operable Object Classes 

The security parameters can be found in [Edit] » [System Parameter Settings] » 

[Security].  

 

Up to 12 sets of user and password are available. Password should be one non-negative 

integer. There are six security classes: A to F. 

Once the password is entered, the objects that the user can operate are classified. As 

shown below, ñUser 1ò can only operate objects with class A or class C. 
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10.2 Object Security Settings 

[Safety control] 

Use [Min. press time (sec)] to 

avoid miss operations. Press and 

hold the object longer than the 

[Min. press time] set here to activate the object. 

[Display confirmation request] After pressing the 

object, a dialog appears for operation confirmation. If 

the response to this dialog comes later than the set 

[Max. waiting time (sec)], this dialog disappears 

automatically and the operation will be canceled. 

 

[Interlock] 

When this check box is selected, 

the specified Bit address is used 

to enable or disable the object. 

As shown, if LB-0 is ON, the 

object is enabled. 

[Hide when disabled] When 

the specified Bit is OFF, hide the object.  

[Grayed label when disabled] When the specified Bit is OFF, the 

label font of the object turns gray. 

 

[User restriction] 

Set the security class of the 

object to be operated by an 

authorized user. 

[Object class]  

ñNoneò means any user can operate this object.  

[Disable protection permanently after initial activation] Once the permitted class of the 

user matches that of the object, the system will stop checking the security class permanently, 

that means, any user can operate this object freely after it is unlocked. 

[Display warning message if access denied] When 

an unauthorized user attempts to operate the object, a 

warning dialog (Window no. 7) appears. The content of 

the message in the dialog can be modified. 

[Make invisible while protected] When the user's privilege does not match the object class, 

hide the object. 
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10.3 Example of Object Security Settings 

The following shows an example of setting object security class: 

1. Create a project, go to [System Parameter Settings] » [Security] » [General] to enable 

3 users: 

User 1 = 

Operable class: A 

User 2 = 

Operable class: A, B 

User 3 = 

Operable class: A, B, C 

 

2. Design Window no. 10 as shown: 

Create two [Numeric Input] objects: 

[LW-9219]  

User no. (1~12)  

Length = 1word 

[LW-9220]  

For entering user password. 

Length = 2 words 

Create a [Numeric Display] object  

[LW-9222]  

Displays the status of current user.  

(16-bit Binary) 

Create a [Set Bit] object 

[LB-9050] logout 

 

Create three [Set Bit] objects, each set to different classes but all select [Made invisible 

while protected]. 

 

After setting, please save and compile the project and execute off-line simulation. The below 

shows how it works when simulating. 
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3. Before entering the password, it displays ñ0000000000000000ò, which means that the 

user operable object class is ñNoneò. [Class A Button] ~ [Class C Button] objects are 

classified from ñAò to ñCò and selected [Made invisible while protected]; therefore they are 

hidden at this moment. 

4. Enter User 1 password ñ111ò. 

Since User 1 is only allowed to operate 

class A objects, [Class A Button] object 

appears for operating. [LW-9222] bit 0 

turns to ñ1ò means that user can 

operate class A objects. 

5. Enter User 3 password ñ333ò. 

Since User 3 is allowed to operate 

class A, B, C objects, [LW-9222] bit 0 

~ bit 2 turns to ñ1ò, means that user 

can operate class A ~ C objects. 

6. Click [Logout] button to log out, the 

system will return to the initial state, 

and current user can only operate 

class ñNoneò objects. 
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ƴ Password input: If the password is incorrect, [LB-9060] will be ON; if the password is 

correct, [LB-9060] will be OFF. All user passwords (User 1 to User 12) can be obtained from 

system registers [LW-9500] ~ [LW-9522], 24 words in total. 

ƴ Changing password directly on HMI: When [LB-9061] is set ON, the system will read 

data in [LW-9500] ~ [LW-9522] to update user password. The new password will be used in 

the further operations. Please note that the user operable object classes will not be changed 

due to the change of password. 
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Chapter 11 Index Register 
 

11.1 Introduction 

 

EasyBuilder provides Index Registers for users to change addresses flexibly. With Index 

Registers, users can change objectôs read/write address directly on HMI without changing its 

settings. There are 32 Index Registers, divided into 16-bit and 32-bit. 

 

 

 

 

 

 

 

 

 

16-bit Index Register: 

Index 0 [LW-9200] (16-bit)~ 

Index 15 [LW-9215] (16-bit) 

Max. address range: 65536 words. 

 

 

32-bit Index Register: 

Index 16 [LW-9230] (32-bit)~ 

Index 31 [LW-9260] (32-bit) 

Max. address range: 4294967296  

words. 

 

While using [Index register], the address is designated by the following equation:  

The constant set in [Address] + the value in the chosen Index Register. 

 

 

Index Registers work for all devices in [System Parameter Settings] » [Device list], but 

are limited to word registers only.

Address 

Address 
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11.2 Examples of Index Register 

 

The following examples show how to use Index Registers. 

  

If not selecting [Index 

register] check box and 

set read address to 

[LW-10]. The system will 

directly read / write LW-10. 

 

 

If select [Index register] 

check box and set index 

register to [INDEX 0]. 

Read address = [LW-0 + 

INDEX 0] 

As shown in the beginning, 

Index 0 indicates register 

[LW-9200]. If the data in 

[LW-9200] is ñ5ò, read 

address is set to [LW(0+5)] = [LW-5]. 

 

Hereôs a demo project shown as an example: 
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Index Function of Word 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Index Function of Bit 

In the same way, Index Register can be used for Bit address. 

1 Word = 16 Bit, adding 1 in the value of index register = adding 16  

 

The switch [LB-0 + Index 6] reads LB-16 = ON 

Index 6 is set to 2 The switch [LB-0 + Index 6] reads LB-32 = OFF 

Index 6 (LW-9206) 

is set to 1 

If the value in 

Index 0 (LW-9200) 

is 0. 

 

Read [LW-0 + Index 0] 

= Read [LW-0] 

 

[LW-10] is set to 3 

[LW-20] is set to 6 

If the value in  

Index 0 (LW-9200)  

is 10 

Read [LW-0 + Index 0] 

= Read [LW-10] = 3 
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Â When using Index Registers for bit addresses, 16 bit addresses will be calculated as 

one unit. EX: If the target is LB-0, and set the value in Index Register to 1, LB-16 will be 

activated. If set the value in Index Register to 2, LB-32 will be activated. 

 

Index Register is used to change addresses. Through changing the data in Index Register, 

user can make an object to read and write different addresses without changing its own 

address settings. Therefore user can transmit or exchange data among different addresses. 

 

 

Please confirm your internet connection before downloading the demo project. 

ftp://ftp.weintek.com/MT8000/Project/System_Sample/Index_Function.zip
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Chapter 12 Keyboard Design and Usage 
 

Numeric Input and ASCII Input objects need keyboard as an input tool. 
Both numeric keyboard and ASCII keyboard are created with Function Key object. 
The types of the keyboards are: 
 

1. Fixed Keyboard. 

 
 

2. Popup Keyboard. 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

3. UNICODE Keyboard. 

 

 

 

Popup keyboard 

Fixed keyboard  
on the window 

Popup keyboard 

without title bar. 

Popup keyboard 

with title bar. 
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12.1 Steps to Design a Popup Keyboard 
 

Step 1 Create and open a window for the new keyboard. For example, set to ñwindow no. 

200ò. 

 
 

Step 2 Adjust the height and width of ñwindow no. 200ò and create a variety of Function Key 

objects in [ASCII/UNICODE mode]. 

For example: 

 

[FK_11] is used as the [Esc] key. 

 

 

[FK_14] is used as the [Enter] key. 

 

 

FK_11 

FK_14 

FK_0 
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The rest are mostly used to enter numbers. For example, [FK_0] is used for entering number 

ñ1ò. 

 

 

Step 3 Select a suitable picture for each Function Key object and placed at the bottom layer 

as a background. 

 
 

Step 4 Select [System Parameter Settings] » [General] » [Keyboard] » [Add] to add 
ñwindow no. 200ò. Up to 32 keyboards can be added. 
 

 

 

Step 5 After the keyboard window is added, when creating Numerical Input and ASCII Input 

objects, ñ200. Keyboardò can be found in [Data Entry] » [Keyboard] »  

[Window no.]. The [Popup position] is for designating the display position of the keyboard 

on the screen. The system divides the screen into 9 areas. 
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Step 6 Select ñ200.Keyboardò. When users press Numerical Input or ASCII Input objects on 

the screen, ñwindow no. 200ò will pop up. Users can press the keys on the keyboard to enter 

data. 
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12.2 Steps to Design a Keyboard with Direct Window 
 
Step 1 Create a Direct Window object and set a read address to activate it. 

In [General] » [Attribute] select [No title bar] and the correct [Window No.]. 

 

 

 

Step 2 Open the setting dialog of Direct Window again to set the [Profile] to the same size as 
the created keyboard window. 

 

 

 

Step 3 Create a Numeric Input object, and donôt select [Use a popup keypad] check box. 
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Step 4 Create a Set Bit object, set address to [LB-0] and set [Set style] to [Set ON]. 

Overlay it on the Numeric Input object. Pressing the Numeric Input object will open the 

keyboard and the Direct Window. 

 

 
 

Step 5 Add Set Bit objects on the [Enter] and [ESC] function keys respectively. Set address 
to [LB-0] and [Set style] to [Set OFF]. In this way when pressing either [Enter] or [ESC] key 
will close the keyboard and the Direct Window. 
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12.3 Steps to Design a Fixed Keyboard on Screen 

 

Users can also place a fixed keyboard on the screen instead of popup keyboard or Direct 
Window. This type of keyboard canôt be moved or closed. 
 
Step 1 
Create a Numeric Input object, in [Data Entry] è [Keyboard] donôt select [Use a popup 
keypad] check box. 

 
 
Step 2 
Use Function Keys to design the keyboard and place it on the screen. 
 

 
Step 3 
Press the Numeric Input object and enter a value with function keys directly. 
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12.4 Steps to Design a UNICODE Keyboard 

 

Create a UNICODE keyboard with Function Keys. 

Step 1 Place an ASCII Input object on the window and select [Use UNICODE] check box. 

Step 2 Create Function Keys [Ŭ] [ɓ] [ɔ] [ŭ] as shown, and an [Enter] key. A simple 

UNICODE keyboard is created. 
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Chapter 13 Objects 

 

This chapter explains the ways of using and setting different kinds of objects. To set the 

general properties of the objects, please refer to the relevant chapters as listed below: 

Shape, Label, Profile 

Please refer to ñChapter 9 Object General Propertiesò. 

Security 

Please refer to ñChapter 10 Securityò 

Index Register 

Please refer to ñChapter 11 Index Registerò 

Label Tag Library 

Please refer to ñChapter 15 Label Library and Multi-language Usageò 

Address Tag Library 

Please refer to ñChapter 16 Address Tag Libraryò 
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13.1 Bit Lamp 

 

Overview 

[Bit Lamp] object displays the state of a designated bit address. If the bit state is OFF, the 

State 0 shape will be displayed. If the bit state is ON, the State 1 shape will be displayed. 

 

 

 

Configuration 

Click the [Bit Lamp] icon on the toolbar to open a [Bit Lamp] object property dialog. 

Set up the properties, press OK button, and a new [Bit Lamp] object will be 

created. 

. 
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Description 

User can describe the information of the object. 

 

Read address 

Click [Setting] to select the [PLC name], [Address], [Device type], [System tag], [Index 

register] of the bit device that controls the [Bit Lamp] object. Users can also set address in 

[General] tab while adding a new object. 
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[Invert signal] 

Reverses the display of ON / OFF states. For example, if [Invert signal] check box is 

selected, when the designated bit is OFF, the object displays ON state. 

 

Blinking  

The appearance of the object may alternate between states when the bit is ON or OFF. 

a. None 

No blinking. 

b. Alternating image on state 0 

The appearance of the object alternates between State 0 and 1 when the bit is OFF. 

c. Alternating image on state 1 

The appearance of the object alternates between State 0 and 1 when the bit is ON. 

d. Blinking on state 0 

The State 0 appearance of the object will blink when the bit is OFF. 

e. Blinking on state 1 

The State 1 appearance of the object will blink when the bit is ON. 
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13.2 Word Lamp 

 

Overview 

[Word Lamp] object displays the state according to the value of a designated word register. 

Up to 256 states are available. When the value of the register is 0, State 0 appearance of the 

object is displayed, and value 1 displays State 1, and so on. 

 

 

 

 

 

 

 

Configuration 

Click the [Word Lamp] icon on the toolbar to open a [Word Lamp] object property 

dialog. Set up the properties, press OK button, and a new [Word Lamp] object will 

be created. 

 



                                                                            Object 
 

 131 

 

 

[Mode] / [Offset]  

Word lamp object offers the following three modes for selection: 

a. Value 

The state is displayed according to the value in the designated word address and plus or 

minus the [Offset].  

As shown below, if the value within LW-200 is 3, since the offset is set to 3, the shape of 

state 6 is displayed. (value 3 + offset 3) 
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b. LSB 

Convert the value from decimal to binary. The least significant active bit in a binary data 

word selects the state displayed. 

  

Decimal value Binary value Displayed state 

0 0000 State 0 displayed. All the bits are 0. 

1 0001 State 1 displayed. The least significant active bit is 

bit 0. 

2 0010 State 2 displayed. The least significant active bit is 

bit 1. 

3 0011 State 1 displayed. The least significant active bit is 

bit 0. 

4 0100 State 3 displayed. The least significant active bit is 

bit 2. 

5 0101 State 1 displayed. The least significant active bit is 

bit 0. 

6 0110 State 2 displayed. The least significant active bit is 

bit 1. 

7 0111 State 1 displayed. The least significant active bit is 

bit 0. 

8 1000 State 4 displayed. The least significant active bit is 

bit 3. 
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c. Change state by time 

The state displayed changes on a time-base. The frequency can be set. 

 

Read address 

Click [Setting] to select the [PLC name], [Address], [Device type], [System tag], [Index 

register] of the word device that controls the [Word Lamp] object. Users can also set address 

in [General] tab while adding a new object. 

 

 

 

Attribute 

[No. of states] 

The number of states is utilized by the object. The state is numbered from 0, so the number 

of states minus 1 will be the state number. If the value within the word register is Ó [No. of 

states] defined in Attribute, the highest state will be displayed. 

If the number of states is set to 8, the valid states will be 0, 1, 2, é, 7. In this case if the word 

value is 8 or higher, the system will display the state 7 shape. 
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In [Label] tab, Language 1 determines the relevant settings of the font. For Language 2~8, 

only the font size can be changed and other settings follow Language 1. 
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13.3 Set Bit  

 

Overview 

The [Set Bit] object provides two operation modes: manual or automatic. Manual mode can 

trigger a designated bit address to change the state between ON and OFF when the object 

is touched. In automatic mode, the bit is automatically activated when a pre-defined 

condition occurs, touching the button will not be effective. 

 

Configuration 

Click the [Set Bit] icon on the toolbar to open a [Set Bit] object property dialog. Set 

up the properties, press OK button, and a new [Set Bit] object will be created. 
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Write address 

Click [Setting] to select the [PLC name], [Address], [Device type], [System tag], [Index 

register] of the bit device that controls the [Set Bit] object. Users can also set address in 

[General] tab while adding a new object. 
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[Write after button is released] 

If this function is selected, the action is delayed till button is released; otherwise, the action is 

executed once the button is pressed. This function does not work with momentary buttons. 

 

Attribute 

[Set Style] Please refer to the following description for different types of operation mode. 

 

Set style Description 

Set ON Set ON the designated bit of the device. 

Set OFF Set OFF the designated bit of the device. 

Toggle Alternates the bit state each time pressed. 

Momentary Holds the bit ON only while button is pressed. 

Periodical toggle Set a designated bit ON and OFF at a set time interval. Time 

interval can be selected the range: 0.1~25.5 seconds.  

Set ON when window 

opens 

Set ON the bit within the window when the window opens. 

Set OFF when window 

opens 

Set OFF the bit within the window when the window opens. 

Set ON when window 

closes 

Set ON the bit within the window when the window closes. 

Set OFF when window 

closes 

Set OFF the bit within the window when the window closes. 

Set ON when 

backlight on 

Set the bit ON when the backlight is turned ON. 

Set OFF when 

backlight on 

 

Set the bit OFF when the backlight is turned ON. 

Set ON when 

backlight off 

Set the bit ON when the backlight is turned OFF. 

Set OFF when 

backlight off 

Set the bit OFF when the backlight is turned OFF. 

 

Macro 

[Set Bit] object can trigger the start of a Macro routine when the Macro has been created in 

advance. Please refer to ñChapter 18 Macro Referenceò for more information. 
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Trigger Mode 

 

 

 

If [Set style] is set to [Toggle], there is a further selection to make of whether the macro 

operates after: 

OFF->ON   OFF to ON transition 

ON->OFF   ON to OFF transition 

ON<->OFF  At both of the changes of state. 
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13.4 Set Word 

 

Overview 

The [Set Word] object provides two operation modes: manual or automatic. Manual mode 

can change the value in a designated word address when the object is touched. In automatic 

mode, the word register is automatically activated when a pre-defined condition occurs, 

touching the button will not be effective. 

 

Configuration 

Click the [Set Word] icon on the toolbar to open a [Set Word] object property 

dialog. Set up the properties, press OK button, and a new [Set Word] object will be 

created. 
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Write address 

Click [Setting] to select the [PLC name], [Address], [Device type], [System tag], [Index 

register] of the word device that controls the [Set Word] object. Users can also set address in 

[General] tab while adding a new object. 
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[Write after button is released] 

If this function is selected, the action is delayed till button is released; otherwise, the action is 

executed once the button is pressed.  

 

Notification 

If this check box is selected, it will notify a designated bit address (setting ON or OFF). 

 

 

[Before writing] / [After writing] 

Set the state of the designated bit address before or after the manual operation. 

Click [Setting] to select the [PLC name], [Address], [Device type], [System tag], [Index 

register] of the Notification bit. Users can also set address in [General] tab while adding a 

new object. 
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Attribute 

[Set style] Select the button action from the drop down list: 

 

Â Write constant value 

Preset a register with the value entered. Each time when the button is pressed, it writes the 

[Set value] to the designated register. Data format is as set by the [Write address]; it can 

be 16-bit BCD, 32-bit BCD, é32-bit float. As shown below, when the button is pressed, 

preset the register with 12. 

 

 

Â Increment value (JOG+) 

Increase value in register by a set amount in [Inc. value], each time when the button is 

pressed, to the [Upper limit]. As shown below, each time when pressing the button, increase 

1 in the designated register, till the value is 10. 

 
 

Â Decrement Value (JOG-) 

Decrease value in register by a set amount in [Dec. value], each time when the button is 

pressed, to the [Bottom limit]. As shown below, each time when pressing the button, 

decrease 1 in the designated register, till the value is 0. 
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Â Press and hold increment (JOG++) 

When the button is held longer than a set time in [JOG delay], it will increase the value in a 

register by a set amount in [Inc. value] at a set rate in [JOG speed], to the [Upper limit]. 

As shown below, when the button is pressed, increase the value in the designated register 

by 1. When the button is held longer than 1 second, increase the value in register by 1 every 

0.5 second, till the value is 10. 

 
 

Â Press and hold increment (JOG--) 

When the button is held longer than a set time in [JOG delay], it will decrease the value in a 

register by a set amount in [Dec. value] at a set rate in [JOG speed], to the [Bottom limit]. 

As shown below, when the button is pressed, decrease the value in the designated register 

by 1. When the button is held longer than 1 second, decrease the value in register by 1 

every 0.5 second, till the value is 0. 

 

 

Â Periodical JOG++ 

An automatic function which operate the designated word address to increase the value in 

the register by a set amount in [Inc. value], at a set rate in [Time interval], to the [Upper limit]. 

As shown below, the system will automatically increase the value in the register by 1 every 

0.5 second, till the value is 10. Then the value returns to 0 and add 1 every 0.5 second 

again. 
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Â Automatic JOG++ 

An automatic function which operate the designated word address to increase the value in 

the register by a set amount in [Inc. value], at a set rate in [Time interval], to the [Upper limit], 

then hold this value. As shown below, the system will automatically increase the value in the 

register by 1 every 0.5 second, till the value is 10, and then stops. 

 

 

Â Automatic JOG-- 

An automatic function which operate the designated word address to decrease the value in 

the register by a set amount in [Dec. value], at a set rate in [Time interval], to the [Bottom 

limit], then hold this value. As shown below, the system will automatically decrease the value 

in the register by 1 every 0.5 second, till the value is 10, and then stops. 

 
 

Â Periodical bounce 

Increases the word address value to the [High limit] by a [Inc. value] at a set rate in [Time 

interval], then decreases to the [Low limit] by the same value at the same rate. As shown 

below, the system will increase the value in the designated register by 1 every 0.5 second, 

till the value is 10, and then decrease the value by 1 every 0.5 second till the value is 0 

whenever the screen is active. 
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Â Periodical step up 

Step up to the [High limit] by [Inc. value] at a set rate in [Time interval], then reset 

immediately to the [Low limit]. The action repeats whenever the screen is active. As shown 

below, the system will increase the value in the designated register by 1 every 0.5 second, 

till the value is 10, and then reset to 0 and increase again, and the action repeats. 

 

 

Â Periodical step down 

Step down to the [Low limit] by [Dec. value] at a set rate in [Time interval], then reset 

immediately to the [High limit]. The action repeats whenever the screen is active. As shown 

below, the system will decrease the value in the designated register by 1 every 0.5 second, 

till the value is 0, and then reset to 10 and decrease again, and the action repeats. 

 
 

Â Set when window opens 

Automatic function occurs whenever the screen is active. The value entered in [Set value] is 

set into the word address when the action occurs. As shown below, when the window opens, 

the system enters 5 into the designated register. 

 

 

Â Set when window closes 

Automatic function occurs whenever the screen is inactive. The value entered in [Set value] 

is set into the word address when the action occurs. As shown below, when the window 

closes, the system enters 5 into the designated register. 
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Â Set when backlight on 

Automatic function occurs whenever the backlight is active. The value entered in [Set value] 

is set into the word address when the action occurs. As shown below, when the backlight 

turns ON, the system set 5 into the designated register. 

 

 

Â Set when backlight off 

Automatic function occurs whenever the backlight is inactive. The value entered in [Set 

value] is set into the word address when the action occurs. As shown below, when the 

backlight turns OFF, the system set 5 into the designated register. 

 

 

Â Cyclic JOG+ 

Each time when the button is pressed, increase the word address value to the [Upper limit] 

by [Inc. value] then reset to the [Bottom limit]. As shown below, each time when pressing the 

button, the system will increase the value in the designated register by 1, till the value is 10, 

and then reset to 0 and increase again by pressing the button. 

 
 

Â Cyclic JOG- 

Each time when the button is pressed, decrease the word address value to the [Bottom limit] 

by [Dec. value] then reset to the [Upper limit]. As shown below, each time when pressing the 

button, the system will decrease the value in the designated register by 1, till the value is 0, 

and then reset to 10 and decrease again by pressing the button. 
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Â Cyclic JOG++ 

When the button is held longer than a set time in [JOG delay], increase the value in a 

register by a set amount in [Inc. value] at a set rate in [JOG speed], to the [Upper limit], then 

reset to the [Bottom limit]. As shown below, when the button is held longer than 0.5 second, 

increase the value in the designated register by 1 every 0.1 second, till the value is 10, and 

then reset to 0 and increase again by holding the button.  

 

Â Cyclic JOG- - 

When the button is held longer than a set time in [JOG delay], decrease the value in a 

register by a set amount in [Dec. value] at a set rate in [JOG speed], to the [Bottom limit], 

then reset to the [Upper limit]. As shown below, when the button is held longer than 0.5 

second, decrease the value in the designated register by 1 every 0.1 second, till the value is 

0, and then reset to 10 and decrease again by holding the button.  
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13.5 Function Key 

 

Overview 

The [Function Key] object can be used for several tasks: 

1. Open / close / return to a screen window.  

2. For keypad design 

3. Execute a Macro 

4. Print screen 

 

Configuration 

Click the [Function Key] icon on the toolbar to open a [Function Key] object 

property dialog. Set up the properties, press OK button, and a new [Function Key] 

object will be created. 
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[Activate after button is released] 

If this function is selected, the action is delayed till button is released, otherwise, the action is 

executed once the button is pressed.  
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[Change full-screen window] Change to another base window. 

 

[Change common window] Change common window. 

 

[Display popup window] 

A pop up window displays in the base window. If [Close this popup window when parent 

window is closed] check box is selected, the pop up window will be closed when change 

the base window to another window. Otherwise, a function key in the pop up window is 

needed to close it. 

 

 

[Return to previous window] 

If this is selected, the Function Key will change from the current screen to the previous one 

displayed. For example, when window no. 10 is changed to window no. 20, press the 

function key to return to window no. 10. This function is only available for base window. 

 

[Close window] Close any active popup windows, message windows included. 

 

[ASCII/UNICODE mode]  

Configures the button as a keypad key, and the character it enters, via [Numeric Input] or 

[ASCII Input] objects. 

 

 

[Enter] Same as the keyboardôs ñenterò function. 

[Backspace] Same as the keyboardôs ñbackspaceò function. 

[Clear] Clear the value in the word register. 

[Esc] Same as the [Close window] function, it is used to close the keyboard window. 

[Delete] Same as the keyboardôs ñDeleteò function, deletes the number or character on the 

right side of the text cursor. 

[Left] Same as the keyboardôs ñŶò key, moves the text cursor to the left side of the previous 

number or character. 

[Right] Same as the keyboardôs ñŸò key, moves the text cursor to the left side of the next 

number or character.  

[ASCII/UNICODE] Specify the character to be entered by this key. 
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[Execute Macro] 

Select this check box to execute one of the Macros from the drop down list that has already 

been configured by users. 

 

[Window title bar] 

[Function Key] defined can be used to move a popup window which is no [window title bar] to 

a preferred position on screen. Select the popup window and then click on a preferred 

position, the window will be moved. 

 

[Screen hard copy] 

Print the current window. Before using this function, choose a printer model in [System 

Parameter Settings] » [Model] » [Printer].  

If a single color printer is used, selecting [grayscale] can get a better print result, but the text 

may not be clearly printed. To improve text printing, it is not necessary to select [grayscale]. 

 

Notification 

If this selection is enabled, it will notify a designated bit address to set ON or OFF, each time 

the button is pressed.  

 

1. Chapter 6 Window Operations 

2. Chapter 12 Keypad Design and Usage 
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Design Non-ASCII character keyboard 

The following explains how to enter and display non-ascii characters in HMI, such as 

Traditional Chinese, Simplified Chinese, Japanese, Greek and so on. 

Please follow the steps. 

 

Step1: Setting non-ascii fonts 

Add the needed non-ascii fonts in [System Parameter Settings] » [Font]. 

Please use the required font for the language used. 

 

 

 

Step2: Design non-ascii keyboard 

Create ñwindow no.11ò and design the non-ascii keyboard. The following use Simplified 

Chinese as an example. 

 

 

 

 

 

The objects in this window are all Function Keys that are set to the needed functions as 

labeled. Take the ñò Function Key as an example, create a function key in [ASCII] / 

[UNICODE] mode, as shown below. 
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In the [Label] tab, select [Use label], type ñ ò in [Content] and select ñAR MingtiM GBò, 

which must be a font set in step 1, as shown below. 

 

The Function Keys used for typing non-ascii characters in the same keyboard must all use 

the same font. For example, in a Simplified Chinese keyboard, use ñAR MingtiM GBò in each 

key for entering characters. 

 

 
 










































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































